Mengatasi Serangan Open Recursive DNS di MikroTik

Saat ini perangkat MikroTik sudah tidak bisa lagi dipandang sebelah mata karena sudah banyak yang mulai menggunakannya. Namun dari banyaknya pengguna tersebut masih banyak yang kurang mengerti dasar-dasar keamanan pada MikroTik. Maka dari itu saya akan coba membahas salah satu teknik untuk menghadapi yang namanya celah Open Recursive DNS.

Serangan Open Recursive DNS

Serangan Open Recursive DNS adalah penggunaan IP dari Router kita sebagai DNS server oleh orang lain di luar jaringan kita. Hal ini biasanya ditandai dengan tingginya bandwidth unggah Router yang menuju ke Internet. Apa efek yang disebabkan oleh hal ini? Internet yang kita gunakan menjadi lebih lambat.

Pada Router dengan sistem operasi keluaran MikroTik yaitu RouterOS hal ini dipicu karena ketika mengizinkan Router menjadi DNS Server. Kalau teman-teman pergi ke IP > DNS di sana ada pilihan Allow Remote Requests yang berarti mengizinkan IP dari Router digunakan sebagai DNS Server. Inilah letak kesalahan orang yang baru belajar MikroTik, karena walau sebenarnya dia tidak menggunakan tapi asal centang saja. Intinya yang penting sesuai dengan tutorial yang ada di Internet.

Mengetahui Router Terkena Serangan

Untuk mengetahui Router terkena serangan atau tidak teman-teman bisa mengecek apakah bandwidth upload pada antarmuka jaringan yang langsung ke internet simetris dengan yang ada di lokal? Jika beda-beda tipis sih tidak masalah tetapi jika bedanya tinggi sekali maka perlu dicurigai. Jika sudah merasa curiga maka lakukan Torch pada antarmuka yang mengarah ke Internet seperti di bawah ini dan lihatlah bahwa bandwidth upload kurang wajar. Untuk lebih memastikan kalian coba cari saja informasi IP tersebut, untuk saya sendiri sudah beberapa kali IP dari negara Tiongkok.

Mendeteksi serangan Open Recursive DNS di MikroTik

Mengatasi Open Recursive DNS

Ada 2 pilihan yang bisa teman-teman lakukan yaitu dengan mematikan fungsi DNS Server pada Router kita dengan melakukan unchecklist pada pilihan Allow Remote Request pada konfigurasi DNS.

Mengatasi Open Recursive DNS di MikroTik

Kalau teman-teman ternyata masih membutuhkan Router MikroTik sebagai DNS Server maka kita bisa melakukan pemblokiran permintaan DNS ke antarmuka jaringan yang terhubung ke internet. Contohnya adalah dengan menggunakan perintah di bawah ini. Oh yaa teman-teman jangan untuk langsung copy paste perintah tersebut ke Router yaa karena kemungkinan akan langsung muncul pesan kesalahan. Pastikan bahwa variabel pada in-interface adalah antarmuka jaringan yang menuju ke Internet.

/ip firewall filter
add chain=input dst-port=53 in-interface=internet protocol=tcp action=drop
add chain=input dst-port=53 in-interface=internet protocol=udp action=drop

Sekedar menjelaskan maksud dari perintah tersebut, jadi kita akan memblokir permintaan yang masuk dari Internet  (input > internet) yang meminta DNS (TCP & UDP port 53).

Pengecekan Berhasil atau Tidak

Untuk melakukan pengecekan apakah kita sudah berhasil atau tidak bisa dilakukan dengan cara melihat langsung apakah trafik yang mencurigakan tadi masih berjalan atau tidak. Selain itu kita juga bisa menggunakan situs web http://openresolver.com yang memeriksa IP Publik dari router kita apakah masih memungkinkan terkena serangan ini atau tidak. Kalau tidak tahu berapa IP Publiknya silahkan ketik saja di kolom pencarian Google dengan kata kunci my ip.

pengecekan dengan opensolver.com

Jika sudah dilakukan sekarang periksa kembali lagi apakah penggunaan bandwidth sudah normal kembali atau belum. Jika belum silahkan tulis masalah kamu pada kolom komentar di bawah karena tampaknya harus ada penanganan khusus 😇.

Tanda
Close